SMBD Error

Posted in Networking on May 14st, 2008 | (2,403) Comments

I had a problem with my Samba Server because of libgcrypt and libgpg-error update. Here is what smbd said:

intranet# smbd -v
/libexec/ld-elf.so.1: Shared object “libgcrypt.so.13″ not found, cure required by “smbd”

First solution is to upgrade the Samba, cheap but I found another error:

=> Patch patch-Makefile.in failed to apply cleanly.
*** Error code 1
Stop in /usr/ports/net/samba3.
*** Error code 1

So to keep it simple (in the stupid way) :D , here are what I did to solve the problem instead of reinstalling Samba:

  1. Locate for the libgcrypt.so.13 that gave me no result.
  2. Go to /usr/local/lib/ and copy the existing libgcrypt.so.15 (caused by update) and give it name: libgcrypt.so.13

    intranet# cp libgcrypt.so.15 libgcrypt.so.13

  3. Run smbd again, and returned this

    intranet# smbd
    /libexec/ld-elf.so.1: Shared object “libgpg-error.so.1″ not found, required by “smbd”

  4. Go to /usr/local/lib/ and copy the existing libgcrypt.so.0(caused by update) and give it name: libgpg-error.so.1

    intranet# cp libgpg-error.so.0 libgpg-error.so.1

  5. Run smbd again

    intranet# smbd
    intranet#

  6. Voila, it works.

I think this trick can be applied to other problems due to “not found shared object”.

Note: I use FreeBSD 5.5-STABLE

RSS